Actualizar Apache, PHP y MySQL en CentOS 5.5

13 comentarios avatar Por Juan Santamaría El 19 de marzo de 2011




Uno de los tutoriales que mas expectación a causado en mi blog por decirlo de alguna manera es el Montaje de un servidor web en CentOS 5.5. Debido a esto he decidido retomarlo después de mucho tiempo y por ello una de las primeras decisiones que he tomado ha sido actualizar los paquetes los cuales hemos ido instalando. Lo primero que me he planteado ha sido buscar un repositorio que me ofreciera todos los paquetes necesarios en uno, es decir, Apache, PHP y MySQL, también conocido como LAMP (Linux, Apache, MySQL, PHP).Y después de rebuscar un poco lo he conseguido, se trata de PowerStack, un proyecto que ha surgido hace poco tiempo y que parece bastante prometedor. Dicho esto, vamos al lio!

Habilitando los repositorios e instalando PowerStack

Nuestro primer paso es habilitar el repositorio para descargar la “aplicación” de PowerStack. Para ello en el terminal escribimos lo siguiente:

[shell]rpm -Uvh http://download.powerstack.org/powerstack-release-0-1.noarch.rpm[/shell]

Despues de este sencillo paso, el siguiente será instalar el repositorio que nos hemos bajado, por tanto tecleamos lo siguiente:

[shell] yum install poo[/shell]

Con esto tendríamos lo necesario ahora solo falta actualizar nuestros paquetes.

Actualizar Apache a la version 2.2.17

Cuando se inicio el tutorial Apache los repositorios oficiales de CentOS albergaban la versión 2.2.3 y es la que se instalo. Sin embargo actualmente la versión mas actual de apache es la 2.2.17.Por tanto para actualizarla escribiremos en el terminal lo siguiente:

[shell]yum -y update httpd[/shell]

Con esto ya estaría instalando y funcionando perfectamente la nueva versión de apache, y no es necesario reiniciar el servidor de forma manual ya que los repositorios de PowerStack lo hace por nosotros.

 

Actualizar PHP a la versión 5.3.5

En el tutorial nos quedamos con la versión de PHP 5.3.3 habiéndola actualizado porque PHPMyAdmin nos lo requería.Ahora vamos a pasar a actualizar a la versión 5.3.5 que es la ultima versión estable de PHP. Para ello tecleamos:

[shell]yum -y update php[/shell]

Al actualizar esta versión deberemos hacer un pequeño arreglo. Este viene dado porque en la ultima versión de PHP la linea destinada a la zona horaria viene comentada y lo que vamos a hacer es descomentarla. Para ello escribimos en el terminal:

[shell]gedit /etc/php.ini[/shell]

Buscaremos la siguiente linea:

[shell];date.timezone =[/shell]

Y la reemplazamos por esta

[shell]date.timezone = "Europe/Madrid"[/shell]

Si queréis ajustarlo a vuestra zona horaria podéis ver las zonas soportadas en el siguiente enlace: Zonas horarias PHP
Actualizar MySQL a la versión 5.5.9

Cuando instalamos MySQL estábamos en la versión 5.0.77.Vamos a pasar a actualizar a la versión 5.5.9.Para ello tecleamos lo siguiente:

[shell] yum -y update mysql[/shell]

Después de realizar todos estos pasos reiniciamos para que se realicen los cambios necesarios y que no tengamos ningún problema. Después de reiniciar si vamos al terminal y escribimos lo siguiente:

[shell]

httpd -v ; mysql -u root-p -e status|grep ‘MySQL Version’; php -i|grep ‘PHP Version’

[/shell]

El resultado de esta prueba debería ser el siguiente:

actualizacion paquetes centos 580x403

Nuestro servidor ya esta actualizado y listo para funcionar.Sin embargo nos quedaría por actualizar phpMyAdmin que ya os contare como hacerlo y ya sabéis, cualquier duda dejar un comentario.

Lo mas buscado





11 comentarios

  1. avatar lomotek
    23 marzo, 2011 at 6:35 AM #

    Muchisimas gracias por el tutorial, he adquirido un Servidor Cloud Dinamico en 1&1 hace unos dias y venia totalmente desactualizado gracias a este tutorial he podido dejarlo actualizado!

  2. avatar JORGE ROMERO
    9 mayo, 2011 at 3:08 AM #

    Hola Juan,

    He seguido los pasos como los has indicado, ya que necesito actualizar mis versiones de php y apache, pero al actualizar el httpd me muestra lo siguiente:

    Resolving Dependencies
    –> Running transaction check
    –> Processing Dependency: httpd = 2.2.3-45.el5.centos.1 for package: httpd-manual
    –> Processing Dependency: httpd = 2.2.3-45.el5.centos.1 for package: httpd-devel
    –> Processing Dependency: httpd = 2.2.3-45.el5.centos.1 for package: mod_ssl
    –> Processing Dependency: httpd = 2.2.3-45.el5.centos.1 for package: httpd-devel
    —> Package httpd.x86_64 0:2.2.17-2 set to be updated
    –> Processing Dependency: httpd-tools = 2.2.17-2 for package: httpd
    –> Running transaction check
    –> Processing Dependency: httpd = 2.2.3-45.el5.centos.1 for package: httpd-devel
    —> Package httpd-devel.x86_64 0:2.2.17-2 set to be updated
    —> Package httpd-manual.x86_64 0:2.2.17-2 set to be updated
    —> Package httpd-tools.x86_64 0:2.2.17-2 set to be updated
    —> Package mod_ssl.x86_64 1:2.2.17-2 set to be updated
    –> Finished Dependency Resolution
    httpd-devel-2.2.3-45.el5.centos.1.i386 from installed has depsolving problems
    –> Missing Dependency: httpd = 2.2.3-45.el5.centos.1 is needed by package httpd-devel-2.2.3-45.el5.centos.1.i386 (installed)
    Error: Missing Dependency: httpd = 2.2.3-45.el5.centos.1 is needed by package httpd-devel-2.2.3-45.el5.centos.1.i386 (installed)

    No se si me puedes orientar para poder corregir el error.

    Muchas gracias y saludos.

    • avatar Juan Santamaría
      12 mayo, 2011 at 5:22 PM #

      Buenas Jorge! Lo primero que se me ocurre es que hagas un httpd -v y mires la versión que tienes y me la digas para analizar porque surge el problema.Parece que esta intentando bajar la version 2.2.3 o algo similar cosa que no existe, de echo la ultima version estable es la 2.2.18 que salio ayer mismo.

      Comentame lo que te devuelve el httpd -v y a partir de ahi valoro haber que puede ser.
      Un saludo y gracias a ti por comentar.

      • avatar JORGE ROMERO
        12 mayo, 2011 at 8:08 PM #

        Hola Juan,

        Gracias por tu respuesta, la versión es la siguiente:

        Server version: Apache/2.2.3
        Server built: May 4 2011 06:51:15

        Realmente me interesa poder hacerlo desde repositorios ya que una instalación manual es algo compleja.

        Saludos y muchas gracias por tu apoyo.

        • avatar Juan Santamaría
          13 mayo, 2011 at 12:30 AM #

          Buenas Jorge, he estado mirando en las listas de correo de centos y parece que he encontrado porque puede ser el problema. He encontrado esto:
          http://lists.centos.org/pipermail/centos/2009-July/079532.html

          Lo que viene a decir es que quizas la arquitectura del sistema que tienes instalada no se corresponde con el paquete httpd adecuado y por tanto habría que desintalar la version actual y instalar la adecuada o bien intentar hacer un update manual , aunque si fuera ese el problema quizas te lo seguiria dando igualmente.

          Mira haber si el paquete httpd instalado corresponde con la arquitectura de tu sistema y sino es asi tendrias que realizar este procedimiento. De todas formas voy a seguir mirando haber si te encuentro alguna solucion mas optima.

          Un saludo.

          • avatar JORGE ROMERO
            15 mayo, 2011 at 7:21 AM #

            Ya pude actualizar el servicio de php y apache, pero tuve un problema al hacer la instalacion de mysql, se me hizo sencillo desinstalarlo y ahora que intento instalarlo de nuevo me marca estos errores:

            yum install mysql-server
            Loaded plugins: fastestmirror
            Loading mirror speeds from cached hostfile
            Setting up Install Process
            Resolving Dependencies
            –> Running transaction check
            —> Package mysql-server.x86_64 0:5.0.77-4.el5_6.6 set to be updated
            –> Processing Dependency: mysql = 5.0.77-4.el5_6.6 for package: mysql-server
            –> Running transaction check
            —> Package mysql.x86_64 0:5.0.77-4.el5_6.6 set to be updated
            –> Finished Dependency Resolution

            Dependencies Resolved

            =============================================================================================================================================================
            Package Arch Version Repository Size
            =============================================================================================================================================================
            Installing:
            mysql-server x86_64 5.0.77-4.el5_6.6 updates 9.8 M
            Installing for dependencies:
            mysql x86_64 5.0.77-4.el5_6.6 updates 4.8 M

            Transaction Summary
            =============================================================================================================================================================
            Install 2 Package(s)
            Upgrade 0 Package(s)

            Total size: 15 M
            Downloading Packages:
            Running rpm_check_debug
            Running Transaction Test
            Finished Transaction Test

            Transaction Check Error:
            file /usr/lib64/mysql/libmysqlclient.so.15.0.0 from install of mysql-5.0.77-4.el5_6.6.x86_64 conflicts with file from package mysqlclient15-5.0.67-1.x86_64
            file /usr/lib64/mysql/libmysqlclient_r.so.15.0.0 from install of mysql-5.0.77-4.el5_6.6.x86_64 conflicts with file from package mysqlclient15-5.0.67-1.x86_64
            file /etc/my.cnf from install of mysql-5.0.77-4.el5_6.6.x86_64 conflicts with file from package mysql-libs-5.5.9-1.x86_64
            file /usr/share/mysql/charsets/Index.xml from install of mysql-5.0.77-4.el5_6.6.x86_64 conflicts with file from package mysql-libs-5.5.9-1.x86_64
            file /usr/share/mysql/charsets/cp1250.xml from install of mysql-5.0.77-4.el5_6.6.x86_64 conflicts with file from package mysql-libs-5.5.9-1.x86_64
            file /usr/share/mysql/charsets/cp1251.xml from install of mysql-5.0.77-4.el5_6.6.x86_64 conflicts with file from package mysql-libs-5.5.9-1.x86_64
            file /usr/share/mysql/czech/errmsg.sys from install of mysql-5.0.77-4.el5_6.6.x86_64 conflicts with file from package mysql-libs-5.5.9-1.x86_64
            file /usr/share/mysql/danish/errmsg.sys from install of mysql-5.0.77-4.el5_6.6.x86_64 conflicts with file from package mysql-libs-5.5.9-1.x86_64
            file /usr/share/mysql/dutch/errmsg.sys from install of mysql-5.0.77-4.el5_6.6.x86_64 conflicts with file from package mysql-libs-5.5.9-1.x86_64
            file /usr/share/mysql/english/errmsg.sys from install of mysql-5.0.77-4.el5_6.6.x86_64 conflicts with file from package mysql-libs-5.5.9-1.x86_64
            file /usr/share/mysql/estonian/errmsg.sys from install of mysql-5.0.77-4.el5_6.6.x86_64 conflicts with file from package mysql-libs-5.5.9-1.x86_64
            file /usr/share/mysql/french/errmsg.sys from install of mysql-5.0.77-4.el5_6.6.x86_64 conflicts with file from package mysql-libs-5.5.9-1.x86_64
            file /usr/share/mysql/german/errmsg.sys from install of mysql-5.0.77-4.el5_6.6.x86_64 conflicts with file from package mysql-libs-5.5.9-1.x86_64
            file /usr/share/mysql/greek/errmsg.sys from install of mysql-5.0.77-4.el5_6.6.x86_64 conflicts with file from package mysql-libs-5.5.9-1.x86_64
            file /usr/share/mysql/hungarian/errmsg.sys from install of mysql-5.0.77-4.el5_6.6.x86_64 conflicts with file from package mysql-libs-5.5.9-1.x86_64
            file /usr/share/mysql/italian/errmsg.sys from install of mysql-5.0.77-4.el5_6.6.x86_64 conflicts with file from package mysql-libs-5.5.9-1.x86_64
            file /usr/share/mysql/japanese/errmsg.sys from install of mysql-5.0.77-4.el5_6.6.x86_64 conflicts with file from package mysql-libs-5.5.9-1.x86_64
            file /usr/share/mysql/korean/errmsg.sys from install of mysql-5.0.77-4.el5_6.6.x86_64 conflicts with file from package mysql-libs-5.5.9-1.x86_64
            file /usr/share/mysql/norwegian-ny/errmsg.sys from install of mysql-5.0.77-4.el5_6.6.x86_64 conflicts with file from package mysql-libs-5.5.9-1.x86_64
            file /usr/share/mysql/norwegian/errmsg.sys from install of mysql-5.0.77-4.el5_6.6.x86_64 conflicts with file from package mysql-libs-5.5.9-1.x86_64
            file /usr/share/mysql/polish/errmsg.sys from install of mysql-5.0.77-4.el5_6.6.x86_64 conflicts with file from package mysql-libs-5.5.9-1.x86_64
            file /usr/share/mysql/portuguese/errmsg.sys from install of mysql-5.0.77-4.el5_6.6.x86_64 conflicts with file from package mysql-libs-5.5.9-1.x86_64
            file /usr/share/mysql/romanian/errmsg.sys from install of mysql-5.0.77-4.el5_6.6.x86_64 conflicts with file from package mysql-libs-5.5.9-1.x86_64
            file /usr/share/mysql/russian/errmsg.sys from install of mysql-5.0.77-4.el5_6.6.x86_64 conflicts with file from package mysql-libs-5.5.9-1.x86_64
            file /usr/share/mysql/serbian/errmsg.sys from install of mysql-5.0.77-4.el5_6.6.x86_64 conflicts with file from package mysql-libs-5.5.9-1.x86_64
            file /usr/share/mysql/slovak/errmsg.sys from install of mysql-5.0.77-4.el5_6.6.x86_64 conflicts with file from package mysql-libs-5.5.9-1.x86_64
            file /usr/share/mysql/spanish/errmsg.sys from install of mysql-5.0.77-4.el5_6.6.x86_64 conflicts with file from package mysql-libs-5.5.9-1.x86_64
            file /usr/share/mysql/swedish/errmsg.sys from install of mysql-5.0.77-4.el5_6.6.x86_64 conflicts with file from package mysql-libs-5.5.9-1.x86_64
            file /usr/share/mysql/ukrainian/errmsg.sys from install of mysql-5.0.77-4.el5_6.6.x86_64 conflicts with file from package mysql-libs-5.5.9-1.x86_64

            Error Summary
            ————-

            Espero me puedas ayudar ya que soy principiante con CENTOS y ahora no se que hacer.

            Gracias.

  3. avatar Andy Garcia
    5 julio, 2011 at 3:25 PM #

    He actualizado apache pero cuando llego a php obtengo este mensaje de error:

    [...]
    You could try using –skip-broken to work around the problem
    You could try running: rpm -Va –nofiles –nodigest

    ¿como podría solucionarlo?

    Mi versión actual de PHP es 5.2.10 y me haría falta alguna más actual de la rama 5.2 preferiblemente.

    • avatar Juan Santamaría
      27 octubre, 2011 at 4:03 PM #

      Eso es debido a que estas saltando de la rama 5.2.x a la rama 5.3.x y por tanto en un principio el repositorio del que hago uso no funciona para dicho proceso que comentas en un principio. Deberias buscar un proceso de actualización entre versiones de la rama 5.2.x

  4. avatar obed
    14 octubre, 2011 at 10:06 PM #

    Hola Juan excelente tuto, estoy actualizando mi servidor CentOS 5.5 para instalar moodle 2, he realizado lo que describes, pero tengo los siguientes errores:

    Server version: Apache/2.2.20 (Unix)
    Server built: Aug 31 2011 23:19:51
    ERROR 2002 (HY000): Can’t connect to local MySQL server through socket ‘/var/lib/mysql/mysql.sock’ (2)
    PHP Version => 5.3.8
    PHP Version => 5.3.8

    ojala pudieras ayudarme a resolverlo, saludos y muchas gracias.

    • avatar Juan Santamaría
      27 octubre, 2011 at 3:57 PM #

      Parece ser que no se ha actualizado correctamente mysql o bien no esta configurado dicho servidor para que se inicie automaticamente. Cuando da ese tipo de error es porque normalmente no se realizo correctamente la conexión.

2 trackbacks

  1. Bitacoras.com (19 marzo, 2011)

    Información Bitacoras.com…

    Valora en Bitacoras.com: Uno de los tutoriales que mas expectación a causado en mi blog por decirlo de alguna manera es el Montaje de un servidor web en CentOS 5.5. Debido a esto he decidido retomarlo después de mucho tiempo y por ello una de las pri…..

  2. [...] CentOS 5.5Categoría: CentOS,Servidor web —Juan Santamaría @ 13:13 Tweet Al igual que actualizamos Apache, PHP y MySQL para nuestro servidor web en esta ocasión vamos a actualizar phpMyAdmin a la ultima versión [...]

Deja un comentario